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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty 
statements accompanying such products and services. Nothing herein should be construed 
as constituting an additional warranty. HP shall not be liable for technical or editorial errors 
or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or 
copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, 
Computer Software Documentation, and Technical Data for Commercial Items are licensed 
to the U.S. Government under vendor's standard commercial license.

Third-Party Web Sites

HP provides links to external third-party Web sites to help you find supplemental 
information.  Site content and availability may change without notice.  HP makes no 
representations or warranties whatsoever as to site content or availability.

Copyright Notices

© Copyright 1993 - 2009 Mercury Interactive (Israel) Ltd.

Trademark Notices

Microsoft®, Windows®, and Windows® XP are U.S registered trademarks of Microsoft 
Corporation.
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Documentation Updates

This guide’s title page contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition, visit the 
HP Quality Center Add-ins site:

From the main Quality Center window, select Help > Add-ins Page.

Additional HP Quality Center documentation is also available by visiting the following URL:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign-in. To register for an HP 
Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.You will also 
receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
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Support

Visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and 
support that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. 
As a valued support customer, you can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. 
Many also require a support contract.  To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 
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Welcome to This Guide

Welcome to HP Enterprise Integration module for SAP solutions, which 
integrates SAP Solution Manager with Quality Center. Using Enterprise 
Integration, you can export SAP Solution Manager business blueprints to the 
Quality Center Requirements module. You can then design and run tests in 
Quality Center based on these requirements and update Solution Manager 
with their results.

Enterprise Integration also enables you to synchronize Quality Center 
defects with support messages that are recorded in the Solution Manager 
Service Desk. You can control the defects and support messages from either 
application.

In addition, when you install Enterprise Integration, the Application Model 
module is installed in Quality Center. You can import the application entity 
hierarchy from your SAP application to the Application Model module, 
enabling you to use the Application Model module to model your SAP 
application within Quality Center. You can then associate entities in the 
Application Model module with Quality Center tests and business 
components, enabling you to plan your testing process based on the 
application entity hierarchy.

Note: This guide explains how to work with SAP Solution Manager in 
conjunction with Quality Center. For more information on using 
Quality Center, refer to the HP Quality Center User Guide. For more 
information on using Solution Manager, refer to the Solution Manager 
documentation.
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How This Guide is Organized

This guide contains the following chapters:

Chapter 1 Setting Up Enterprise Integration

Describes how to install and enable Enterprise Integration.

Chapter 2 Synchronizing Requirements and Blueprints

Describes how to import Solution Manager business blueprints into 
Quality Center and how to update Solution Manager with test results from 
Quality Center.

Chapter 3 Synchronizing Defects and Support Messages

Describes how to synchronize Quality Center defects with Service Desk 
support messages and how to transfer control of the defects from one 
application to the other.

Chapter 4 Working with the Application Model Module

Describes how to import and manage application entities in the Application 
Model module.

Chapter 5 Customizing Enterprise Integration

Describes how to customize permissions and project entities for Enterprise 
Integration.
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Setting Up Enterprise Integration

This chapter describes the installation requirements and setup procedures 
for using Enterprise Integration.

This chapter includes:

 ➤  Prerequisites for Enterprise Integration on page 10

 ➤  The Installation Process on page 10

 ➤  Installing Enterprise Integration on page 12

 ➤  Loading the Enterprise Integration License on page 25

 ➤  Enabling the Enterprise Integration Extension on page 25

 ➤  Upgrading Projects on page 27

 ➤  Installing the SAP Application Importer Component on page 28

 ➤  Uninstalling Enterprise Integration on page 29
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Prerequisites for Enterprise Integration

To use Enterprise Integration, you must have the following installed:

➤ Quality Center 10.00 (on your server machine)

➤ Quality Center 10.00 Patch 4 or later (on your server machine)

➤ SAP Solution Manager 7.0 EhP1 or later

The minimum system requirements to run Enterprise Integration are the 
same as for Quality Center, as described in the HP Quality Center Installation 
Guide. In addition, to import a Solution Manager business blueprint or to 
synchronize a support message containing content in a particular language, 
the Quality Center server machine must be installed on an operating system 
that supports that language.

The Installation Process

This section describes the Enterprise Integration installation process.

To install Enterprise Integration:

 1 Ensure that Quality Center 10.00 is installed on your server machine.

For more information on installing Quality Center, refer to the 
HP Quality Center Installation Guide.

 2 Install Quality Center 10.00 Patch 4 on your server machine.

 a Visit the HP Software Support Web site at http://www.hp.com/go/
hpsoftwaresupport.

 b Under Where do I find, click Software patches and download the patch.

 c Follow the on-screen installation instructions.

 3 Install the Enterprise Integration extension on your server machine.

For more information on installing the Enterprise Integration extension, see 
“Installing Enterprise Integration” on page 12.

http://www.hp.com/go/hpsoftwaresupport
http://www.hp.com/go/hpsoftwaresupport
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 4 Load the Enterprise Integration license.

For more information, see “Loading the Enterprise Integration License” on 
page 25.

 5 Enable the Enterprise Integration extension in Quality Center Site 
Administration for every project that requires Enterprise Integration.

For more information, see “Enabling the Enterprise Integration Extension” 
on page 25.

 6 Install the SAP Application Importer Component on each client machine.

The Application Model module is installed automatically when you install 
Enterprise Integration. To import application entities from your SAP 
application to the Application Model module, the SAP Application Importer 
Component must be installed on each client machine from which you want 
to import application entities. For more information on installing the SAP 
Application Importer Component, see “Installing the SAP Application 
Importer Component” on page 28.
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Installing Enterprise Integration

To install Enterprise Integration, you download the installation files from 
the HP Quality Center Add-ins page and run the installation wizard.

To install Enterprise Integration:

 1 If you are logged in to Quality Center or Site Administration, select Help > 
Add-ins page. Proceed to step 4 on page 13.

 2 Open your Web browser and type your HP Quality Center URL: 
http://<Quality Center server name>[<:port number>]/qcbin. The 
HP Quality Center Options window opens.

 3 Click the Add-ins Page link.
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 4 The HP Quality Center Add-ins page opens.

Click the More HP Quality Center Add-ins link. The More HP Quality Center 
Add-ins page opens.

 5 Under Quality Center User Add-ins, under Quality Center Extensions for 
SAP, click the HP Enterprise Integration module for SAP applications link. 
The HP Enterprise Integration module for SAP applications page opens.

 6 Right-click the Download Enterprise Integration link for your platform and 
click Save Target As. The Save As dialog box opens.

 7 In the Save As dialog box, select a location on your Quality Center server 
machine to save the installation file and click Save.

 8 From your Quality Center server machine, run the appropriate setup file.

If you are working on Solaris, Linux, AIX, or HP-UX platforms:

➤ To install in console mode, use the console option. For example, 
linux_setup.bin -console.

➤ To install in UI mode, make sure that the DISPLAY environment variable 
is properly configured on the Quality Center host machine, and that the 
machine from which you are installing is running an X-server (for 
example, Exceed).

 9 If you are installing over a previous version of Enterprise Integration, a 
message is displayed recommending that you back up any custom 
configurations before continuing.

 10 The Welcome dialog box opens. Click Next.
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 11 The License Agreement dialog box opens.

Read the license agreement. To accept the terms of the license agreement, 
select I accept the terms of the license agreement.

Click Next.
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 12 The Directory Name dialog box opens.

Accept the proposed folder for the Enterprise Integration installation or 
browse for an alternate folder.

Click Next.
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 13 The HP Quality Center Repository Path dialog box opens.

Type the location of the Quality Center repository.

Click Next.
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 14 The Select which product to install dialog box opens.

Select whether to install only Enterprise Integration or Enterprise 
Integration together with other Quality Center extensions:

➤ To install only Enterprise Integration, select Enterprise Integration 2.50.

➤ To install Enterprise Integration together with other Quality Center 
extensions, select Multiple Installation.

Click Next.

 15 If you chose to install only Enterprise Integration, proceed to step 16.

If you chose Multiple Installations, select the extensions that you want to 
install and click Next. For information on other extensions, see the 
documentation for the relevant extension.
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 16 The Installation Summary dialog box opens.

To review or change any settings, click Back.

To accept the settings and start the installation, click Next. The installation 
process starts.
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 17 When the installation process completes, the Update the Server dialog box 
opens.

When you update the Quality Center server, the Enterprise Integration files 
are copied into the opened qcbin.war archive directory in the 
<Quality Center Installation>\application directory. In addition, the 
30EIServer.war and 40EIServerWebSphere.war folders are added. The 
Quality Center Archive and Deployment Tool is launched. This tool enables 
you to update the running Quality Center Web server.

Select an update option:

➤ Update now. Updates the Quality Center archive files and launches the 
deployment tool now.

➤ Update later. To manually update the Quality Center server at a later 
time. You must update the Quality Center server before you can use 
Enterprise Integration.

Click Next. 
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 18 If you selected Update now, proceed to step 20.

If you selected Update later, click Next and then click Finish to close the 
installation setup dialog box. 

 19 When you are ready to update the application server, run the deploy.bat 
script (or deploy.sh for non-Windows systems) from the <Enterprise 
Integration installation> directory. When running the batch file, specify the 
Quality Center installation directory and the location of the Quality Center 
repository, using the format:

deploy <Quality Center installation directory> <Quality Center repository 
directory>

For example:

deploy "C:\Program Files\Mercury\Quality Center" "C:\Program 
Files\Mercury\Quality Center\repository"

 20 After clicking Update now, or manually launching the batch file, the 
Quality Center Archive and Deployment tool opens.
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For Enterprise Integration to work with Quality Center, you must create a 
new archive and redeploy qcbin.war on the application server. This enables 
changes to the archive files to take effect. If Quality Center is deployed on a 
JBoss server, you must redeploy the EIServer.war file. If Quality Center is 
deployed on a WebSphere server, you must redeploy the 
EIServerWebSphere.war file.

Click Next to create the new archive files.

 21 If your application server is JBoss, proceed to step 22.

If your application server is not JBoss, the following dialog box opens.

You must deploy Quality Center manually on the application server after 
the setup process completes. The location of the archive files is shown in the 
dialog box. 

The updated archive files are stored in different formats, although the 
content is the same. The files are stored openly in the 20qcbin.war, 
30EIServer.war, and 40EIServerWebSphere.war folders, and as closed 
archives in qcbin.war, EIServer.war, and EIServerWebSphere.war.
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If Quality Center is deployed on a WebSphere server, you must perform the 
following steps:

 a Deploy the EIServerWebSphere.war file.

 b During the deployment, make sure that you deploy web services, and set 
the context root to EIServer (case sensitive).

 c From the <Quality Center Installation>\application directory, copy the 
SPICore.jar file to the <WebSphere installation folder>\lib folder.

 d Restart the WebSphere server.

Note: For more information on manually deploying Quality Center on an 
application server, refer to the HP Quality Center Installation Guide.

Click Next and proceed to step 24.
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 22 If your application server is not JBoss, proceed to step 24.

If your application server is JBoss, the HP Quality Center Redeployment 
dialog box opens.

Choose one of the following options:

➤ Yes. Deploys the archive files automatically.

➤ No. To manually deploy the archive files later.

Click Next.
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 23 If the Quality Center service is running, the Archive and Deployment Tool 
automatically attempts to stop the service. If the tool is unable to stop the 
service, the Service Not Stopped dialog box opens.

Choose one of the following options:

➤ Retry. Tries stopping the JBoss service again.

➤ Skip JBoss deployment. Cancels the deployment. You must manually 
deploy JBoss later.

Click Next.

 24 When the deployment is complete, the Completion dialog box opens. Click 
Finish to close the Quality Center Archive and Deployment Tool.

 25 Click Finish to close the HP Quality Process for SAP Solutions Setup dialog 
box.

 26 Restart the Quality Center server.
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Loading the Enterprise Integration License

To enable the Enterprise Integration functionality, you must load your 
Enterprise Integration license.

To load the Enterprise Integration license:

 1 In Site Administration, click the Licenses tab.

 2 Click the Modify License button. The License Edit dialog box opens.

 3 Click the Load License button and select the Enterprise Integration license 
file. Alternatively, copy the license file and click Paste License.

 4 Click OK. The license is displayed in the list of licenses.

Enabling the Enterprise Integration Extension

After installing Enterprise Integration on your Quality Center server, you 
must enable the Enterprise Integration extension for a Quality Center 
project. You should enable Enterprise Integration for the project in which 
you want to synchronize the SAP business blueprint and support messages. 
You can enable the extension for either a new project or an existing one.

Note: Projects that were enabled for a previous version of Enterprise 
Integration (for example, Enterprise Integration 2.10 on Quality Center 9.2), 
are automatically enabled for Enterprise Integration 2.50.
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Before enabling the Enterprise Integration extension, consider the following 
points:

➤ You cannot disable an extension for a project after you enable it.

➤ When you enable a project for Enterprise Integration, the Application 
Model module and associated features are also enabled for the project.

➤ If the project is active, you must deactivate it before enabling an extension. 
After the extension has been enabled, you can reactivate the project.

➤ Enabling extensions for a project can take some time.

To enable the Enterprise Integration extension for a project:

 1 In Quality Center Site Administration, click the Site Projects tab.

 2 If relevant, create a new project in Quality Center in which to enable the 
extension. For more information on creating Quality Center projects, refer 
to the HP Quality Center Administrator Guide.

 3 In the Projects list, select a project. In the right pane, click the Project 
Extensions tab. The Extensions list is displayed, listing extensions installed 
on the Quality Center server for which you have a license.

 4 For the Enterprise Integration for SAP applications extension, select the 
Enabled check box, and click Yes to confirm. The Enterprise Integration for 
SAP applications and Application Model extensions are both enabled and a 
confirmation message displays.
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Upgrading Projects

If you worked with Quality Center projects on previous versions of the 
Enterprise Integration extension, you must upgrade those projects to work 
with the current version. 

The following table describes the process required for working with a 
previously created project.

For more information on upgrading projects, refer to the Upgrading 
Projects section in the HP Quality Center Administrator Guide.

From version:
To Quality Center 10.00 with 
Enterprise Integration 2.50:

Quality Center 9.2 with  
Enterprise Integration 2.10

1  Open the qc_9.2_exceptions.xml file. This is 
located by default in the C:\Program 
Files\HP\Quality Center\repository\sa
\DomsInfo\MaintenanceData\dat directory.

2  Between the <excpetions> tags, add the 
following lines:

<IndexMissing>

<object pattern="EI_FM_EX_NAME_IDX" 
type="extra" />

</IndexMissing>

3  Upgrade your projects using Quality Center Site 
Administration 10.00. 

Quality Center 9.2 with  
Enterprise Integration 2.0 
or 2.0 Patch 1

You can upgrade directly to Quality Center 10.00 
with Enterprise Integration 2.50 (see “Quality 
Center 9.2 with Enterprise Integration 2.10”).

However, to make sure all prerequisites and 
verifications are fulfilled, we recommend that you 
perform a gradual upgrade:

1  Upgrade to Quality Center 9.2 with Enterprise 
Integration 2.10.

2  Upgrade to Quality Center 10.00 with Enterprise 
Integration 2.50.
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Installing the SAP Application Importer Component

You must install the SAP Application Importer Component on each 
Quality Center client machine to which you want to import SAP application 
entity hierarchies. The SAP Application Importer Component is the tool 
that communicates with the SAP server and imports application entity data 
from your SAP application to Quality Center.

Notes: 

➤ To install the SAP Application Importer Component, you must have 
Microsoft .NET Framework 2.0 installed on the client machine. You can 
download these from the Microsoft Web site 
(http://www.microsoft.com).

➤ To install the SAP Application Importer Component, you must have 
administrator permissions on the client machine.

To install the SAP Application Importer Component:

 1 From your Quality Center client machine, log in to a project for which 
Enterprise Integration is enabled. The SAP Application Importer Component 
files are downloaded to your client machine.

 2 Locate the APM directory in the Quality Center installation directory (by 
default C:\Program Files\Common Files\Mercury 
Interactive\Quality Center).

 3 Run the SAPAppImporterSetup.exe file located in this folder and follow the 
installation instructions on your screen.
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Uninstalling Enterprise Integration

This section describes how to uninstall Enterprise Integration from your 
server machine.

This section includes the following topics:

➤ “Uninstalling Enterprise Integration from Windows” on page 29

➤ “Uninstalling Enterprise Integration from Non-Windows Systems” on 
page 36

Uninstalling Enterprise Integration from Windows
This section describes how to uninstall Enterprise Integration from 
Windows.

To uninstall Enterprise Integration from Windows:

 1 Make sure that the application server is running.

 2 To open the HP Quality Process for SAP Solutions Uninstall dialog box, you 
can:

➤ Choose Start > Settings > Control Panel > Add/Remove Programs, select 
HP Quality Process for SAP Solutions, and click the Change/Remove 
button. Follow the instructions on your screen.

➤ Locate the Enterprise Integration home directory. By default, the files are 
stored in [drive]:\Program Files\HP\Quality Process for SAP Solutions. In 
the _uninst subdirectory, double-click uninstall.exe.

The HP Quality Process for SAP Solutions Uninstall dialog box opens.
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 3 Click Next. The Update the HP Quality Center Server dialog box opens.

Select an update option:

➤ Yes. To update the archive files and launch the deployment tool now.

➤ No. To update and uninstall later.

Click Next to continue to uninstall, or Cancel to uninstall later.
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 4 The Quality Center Archive and Deployment Tool opens.

To uninstall Enterprise Integration, you need to create a new archive and 
redeploy qcbin.war on the application server. This enables changes to the 
file to take effect.

Click Next to create the new archive files.
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 5 If your application server is JBoss, proceed to step 6.

If your application server is other than JBoss, the following dialog box 
opens.

You must deploy Quality Center manually on the application server after 
the setup process completes. The location of the archive file is shown in the 
dialog box. 

The updated archive file is stored in different formats, although the content 
is the same. The files are stored in the 20qcbin.war folder, and are archived 
in qcbin.war.

To update the archives and undeploy them manually, run the undeploy.bat 
script from the <Enterprise Integration installation> directory. When 
running the batch file, specify the Quality Center installation directory and 
the location of the Quality Center repository, using the format:

undeploy <Quality Center installation directory> <Quality Center repository 
directory>
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For example:

undeploy "C:\Program Files\HP\Quality Center" "C:\Program Files\HP\
Quality Center\repository"

Note: For more information on manually deploying Quality Center on an 
application server, refer to the HP Quality Center Installation Guide.

Click Next and proceed to step 8.

 6 If your application server is other than JBoss, proceed to step 8.

If your application server is JBoss, the HP Quality Center Redeployment 
dialog box opens.

Choose one of the following options:

➤ Yes. To deploy the archive files automatically.

➤ No. To manually deploy the archive files later. 

Click Next to continue.



Chapter 1 • Setting Up Enterprise Integration

34

34

 7 If the Quality Center service is running, the Archive and Deployment Tool 
automatically attempts to stop the service. If the tool is unable to stop the 
service, the Service Not Stopped dialog box opens.

Choose one of the following options:

➤ Retry. To try again to stop the JBoss service.

➤ Skip JBoss deployment. To cancel the deployment and manually deploy 
JBoss later.

Click Next.

 8 When the deployment is complete, the Completion dialog box opens. Click 
Finish to close the Quality Center Archive and Deployment Tool Setup. The 
HP Quality Process for SAP Solutions Uninstall dialog box is displayed.

 9 Click Next. The Update completed dialog box opens.
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 10 Click Next to continue. The File Deletion dialog box opens.

Select Yes to delete the remaining uninstall files in the Enterprise 
Integration directory.

Click Next.

 11 Click Finish to close the HP Quality Process for SAP Solutions Uninstall 
dialog box.
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Uninstalling Enterprise Integration from Non-Windows 
Systems
This section describes how to uninstall Enterprise Integration from 
non-Windows systems, such as Linux or Solaris.

To uninstall Enterprise Integration from non-Windows systems:

 1 Run the Quality Center Archive and Deployment Tool to create a new 
archive and redeploy the qcbin.war file on the application server.

To update the archives and undeploy them manually, run the undeploy.sh 
script from the <Enterprise Integration installation> directory. When 
running the batch file, specify the Quality Center installation directory and 
the location of the Quality Center repository, using the format:

undeploy <Quality Center installation directory> <Quality Center repository 
directory>

 2 Make sure that the application server is running.

 3 Type the following command at the system prompt:

/[directory]/[Enterprise Integration_directory]/_uninst/uninstall

The HP Quality Process for SAP Solutions Uninstall wizard opens.

 4 Click Next. Follow the on-screen instructions.

 5 When you are prompted to delete all add-in files, select Yes.
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Synchronizing Requirements and 
Blueprints

You import Solution Manager blueprints as Quality Center requirements. 
After you test the requirements in Quality Center, you synchronize the test 
results with Solution Manager.

This chapter includes:

 ➤  About Synchronizing Requirements and Blueprints on page 37

 ➤  Configuring Solution Manager on page 38

 ➤  Adding and Editing Business Blueprint Content on page 39

 ➤  Importing Business Blueprints to Quality Center on page 39

 ➤  Assigning Tests to Imported Requirements on page 46

 ➤  Updating Business Blueprints on page 46

About Synchronizing Requirements and Blueprints

Before you can perform requirement and blueprint synchronization, you 
must first configure your Quality Center project to work with Enterprise 
Integration. For more information, see “Enabling the Enterprise Integration 
Extension” on page 25.

After you add content to your Solution Manager business blueprint, you 
import the business blueprint into the Quality Center Requirements 
module. You can associate the imported requirements with tests and run the 
tests in Quality Center, and then update the tests and their results in 
Solution Manager.
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Synchronizing requirements and blueprints involves the following stages:

 1 Create a Solution Manager project and associate it with your Quality Center 
project. Optionally, you can map Solution Manager keywords with 
user-defined fields in Quality Center. For more information, see 
“Configuring Solution Manager” on page 38.

 2 Create a business blueprint in your Solution Manager project. For more 
information, see “Adding and Editing Business Blueprint Content” on 
page 39.

 3 Import your business blueprint to your Quality Center project. For more 
information, see “Importing Business Blueprints to Quality Center” on 
page 39.

 4 Assign and run tests in Quality Center for the imported requirements. For 
more information, see “Assigning Tests to Imported Requirements” on 
page 46.

 5 Update your business blueprint with the test results. For more information, 
see “Updating Business Blueprints” on page 46.

Configuring Solution Manager

You create a project in Solution Manager and associate it with your 
Quality Center project. You can then map keywords in Solution Manager 
with user-defined fields in Quality Center. You can associate each Solution 
Manager project with one Quality Center project only.

To configure Solution Manager:

 1 Create a Solution Manager project in the SOLAR_PROJECT_ADMIN 
transaction. For more information on creating projects in Solution Manager, 
refer to the SAP Application Help.

 2 In the SOLAR_PROJECT_ADMIN transaction, open your Solution Manager 
project and choose Edit > Connection to HP Quality Center.

Enter your Quality Center login details.

 3 Map Solution Manager keywords with user-defined fields in your 
Quality Center project. For more information, see “Mapping Keywords” on 
page 39.
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Mapping Keywords
Before importing the blueprint to a Quality Center project, you can map  
Solution Manager keywords to user-defined fields in Quality Center. You 
first create user-defined fields in the Quality Center project. Keywords can 
be mapped only to user-defined fields of type String or Memo. For more 
information on creating user-defined fields, refer to the HP Quality Center 
Administrator Guide.

You can map more than one keyword to a single user-defined field. The total 
length of all keywords mapped to a specific field cannot exceed the field’s 
size.

Keywords that are not mapped to a specific user-defined field are mapped to 
the default keywords field in Quality Center, SM_KEYWORDS. These are 
separated by semicolons (;). For more information on mapping Solution 
Manager keywords, refer to the SAP Application Help.

Adding and Editing Business Blueprint Content

You add blueprint content as you would to a regular business blueprint, 
using the SOLAR01 transaction. You must also add business requirement 
documents or testing objects in the Transfer to SAP QC by HP tab to the 
blueprint elements you want to export to Quality Center. You can also use 
the SOLAR02 transaction to manage and export business blueprints.

Only blueprint elements that contain requirement documents or testing 
objects are exported to Quality Center. For more information on adding and 
editing business blueprint content, refer to the SAP Application Help.

Importing Business Blueprints to Quality Center

After you have added content to your business blueprint, you import it to 
the Quality Center Requirements module. The blueprint data is imported to 
Quality Center as requirements.

Alternatively, you can send the business blueprint to Quality Center from 
Solution Manager.
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This section includes the following topics:

➤ Guidelines for Importing Business Blueprints to Quality Center on page 40

➤ Business Blueprint Import Example on page 42

➤ Importing Business Blueprints on page 43

➤ Sending Business Blueprints from Solution Manager on page 45

Guidelines for Importing Business Blueprints to 
Quality Center

When you import the business blueprint for an SAP Solution Manager 
project, elements in the blueprint are mapped to requirements and fields in 
the Quality Center Requirements module, according to the following rules:

➤ The blueprint structure is mapped to the Quality Center requirements 
hierarchy. The blueprint title is mapped to a requirement of type Folder 
created under the requirement Solution Manager Blueprints, itself created 
under the root requirement. The name of the requirement is the same as the 
title of the root element. All child elements of the root element are mapped 
as child requirements of the Folder requirement.

➤ Business requirement documents are mapped as Quality Center 
requirements of type Business.

➤ Transactions and other testing objects are mapped as requirements of type 
Testing.

➤ The test object ID of a blueprint element is mapped to the Name field of the 
requirement representing the element.
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➤ Other blueprint element attributes and unmapped administrative keywords 
are mapped to the following Quality Center requirement fields described in 
the table below. These fields are created automatically when you enable the 
Enterprise Integration extension and are read-only.

When you import a business blueprint that has already been imported, 
Enterprise Integration does not create new requirements in Quality Center. 
Instead, the existing requirements in Quality Center are updated. Note the 
following:

➤ Any changes that you made to the structure previously imported from 
Solution Manager are overwritten. For example, suppose you exported a 
business blueprint structure to Quality Center requirements and 
subsequently renamed and moved some of these requirements. When you 
import the business blueprint again, the requirements’ original names and 
locations are restored. To prevent data loss, it is recommended that you do 
not make changes to data imported from Solution Manager.

➤ Any changes you made to requirement fields that were not exported from 
Solution Manager are preserved, in addition to associations with tests or 
child requirements. For example, if you change the Priority field for a 
requirement, the changes you made are not overwritten.

Fields Description

SM Keywords A list of the keywords associated with the business 
blueprint element, separated by semicolons (;).

Only keywords that are not mapped to user-defined fields 
in Quality Center are included in this field. For more 
information, see “Mapping Keywords” on page 39.

SM Logical 
Component

The name of the Solution Manager logical component. 
This field has a value only for requirements of type 
Business representing Solution Manager requirements.

SM Object Code The Solution Manager object code. This field has a value 
only for requirements of type Testing representing 
Solution Manager requirements.

SM Object Type The type of Solution Manager object. This field has a 
value only for requirements of type Testing representing 
Solution Manager requirements.
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➤ If you import a business blueprint element to Quality Center and then 
delete the element in Solution Manager, when you import the business 
blueprint again, the requirement corresponding to the element is moved to 
the Solution Manager Blueprints trash folder. Any data under the 
requirement is also moved to this folder.

➤ Version Control: In version control enabled projects, when you import a 
blueprint, if the corresponding requirement is checked out, the requirement 
is not updated.

Business Blueprint Import Example

Consider the business blueprint structure below. Suppose the only 
requirement in the structure belongs to the process Process 1, and is named 
Requirement for Process 1.

After you import the blueprint structure to Quality Center, the requirements 
tree looks as follows: 
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The blueprint structure root element test is exported as a child requirement 
of the requirement Solution Manager Blueprints. The elements Business 
Scenarios, Test scenario, Business Processes, and Process 1 are exported as 
child requirements of the requirement test. All these requirements are of 
type Folder. The Solution Manager business requirement document 
Requirement for Process 1 is exported as a Quality Center requirement of the 
same name and of type Business. Note that the elements Organizational Units 
and Master Data are not exported as they do not contain any information to 
send.

Importing Business Blueprints
You import business blueprints from Solution Manager to Quality Center.

Note: Only blueprint structure elements containing at least one business 
requirement document or testing object can be imported from Solution 
Manager.

To import business blueprints:

 1 Connect to Quality Center with a user that has the appropriate permissions 
to work with Enterprise Integration. For more information on setting 
Quality Center permissions for Enterprise Integration, see “Customizing 
User Group Permissions for Integration with Solution Manager” on page 84.
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 2 In the upper right side of the Quality Center window, click the Tools button 
and choose SAP Tools > Import Solution Manager Blueprint. The Import 
Solution Manager Blueprint dialog box opens.

 3 Select a blueprint from the list and click Import Solution Manager Blueprint. 
If you are prompted, enter your SAP login and password.
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The SAP Select Substructure dialog box opens, displaying the blueprint 
structure.

 4 Select the blueprint nodes to be imported.

To ensure that all nodes are selected, clear and select the root node.

 5 Click the Continue button.

 6 Click the End Transaction button.

Sending Business Blueprints from Solution Manager

You can export the blueprint content from Solution Manager by choosing 
Business Blueprint > Send data to Quality Center in the SOLAR01 or 
SOLAR02 transaction. For more information, refer to the SAP Application 
Help.
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Assigning Tests to Imported Requirements

You can design and run tests to cover each of the requirements imported to 
Quality Center. You can assign tests to any requirement type imported to 
Quality Center, including the Folder type.

To assign tests to imported requirements:

 1 In the Quality Center Test Plan module, design tests and create coverage 
between them and the imported requirements.

 2 In the Quality Center Test Lab module, create test set folders and test sets.

 3 Create test instances of the tests you created and assign them to the tests.

 4 Run the test instances.

For more information on designing and running tests, see the 
HP Quality Center User Guide.

Updating Business Blueprints

After you run the test instances, you can export the results to Solution 
Manager. For each node in Solution Manager, you can view the associated 
test instances in Quality Center, and their status.

When you update a business blueprint, Quality Center sends information 
about test runs associated with nodes that represent business blueprint 
elements.

This section includes the following topics:

➤ “Blueprint Update Example” on page 47

➤ “Exporting Test Results to Solution Manager Blueprints” on page 48
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Blueprint Update Example

Consider the business blueprint imported in “Business Blueprint Import 
Example” on page 42. Suppose you create a requirement of type Testing to 
test the business requirement document of type Business Requirement for 
Process 1. You create a test Test 1 to test this requirement and assign it to the 
requirement. You then assign an instance of this test to a test set and run the 
test, which passes successfully.

When you update the business blueprint, the test associated with the 
requirement is displayed in Solution Manager. You can see the status of the 
test in the Test State column.
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Exporting Test Results to Solution Manager Blueprints
You export test results from Quality Center to your Solution Manager 
blueprint.

To export test results to a Solution Manager blueprint:

 1 Click the Tools button located on the upper right side of the Quality Center 
window and choose SAP Tools > Update Solution Manager. The Update 
Solution Manager dialog box opens.
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The Update Solution Manager dialog box displays the business blueprints 
previously exported to Quality Center. For each business blueprint, the 
following columns are displayed:

 2 Select the blueprint you want to update and click the Update Blueprint 
Quality button. The Blueprint Update Options dialog box opens.

Fields Description

Blueprint Title The title of the business blueprint.

Blueprint App ID The SAP application ID of the business blueprint.

Last Update The time the business blueprint was last successfully 
updated from Quality Center.

Status The Solution Manager update status. Can have one of the 
following values:

➤ New. The business blueprint was not previously 
updated from Quality Center.

➤ In Progress. Enterprise Integration is currently 
updating the business blueprint.

➤ No Run. No changes were made in the previous 
business blueprint update.

➤ Passed. The business blueprint was successfully 
updated with changes.

➤ Failed. Errors occurred during the previous business 
blueprint update.
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 3 Select one of the following options for updating the business blueprint:

➤ Typical. Sends to Solution Manager only information related to the 
blueprint that you are updating and that was added or updated since the 
previous successful update.

➤ Complete. Sends to Solution Manager all the test coverage and test 
execution information related to the blueprint you are updating. If you 
choose this option, updating the business blueprint may take some time.

 4 Click OK. Enterprise Integration sends the test results to Solution Manager 
according to the option you specified.

You can view this information from the SOLAR_EVAL transaction under 
Analysis > Projects > Testing with SAP Quality Center by HP > Test Results 
for Business Test Requirements. Alternatively, you can view the information 
for a specific requirement from the SOLAR01 transaction by browsing to the 
QC Transfer tab, choosing the object that was tested and clicking the Test 
Results tab of the properties window. For more information, refer to the SAP 
Application Help.



51

3
Synchronizing Defects and Support 
Messages

You can synchronize support messages in the Solution Manager Service Desk 
with defects in Quality Center.

This chapter includes:

 ➤  About Synchronizing Defects and Support Messages on page 51

 ➤  Configuring Solution Manager on page 53

 ➤  Creating Field Mappings on page 53

 ➤  Managing SAP-Related Defects in Quality Center on page 59

 ➤  Exchanging Defect Responsibility on page 61

 ➤  Tracking Defect Synchronization in Quality Center on page 62

About Synchronizing Defects and Support Messages

If you create a new SAP-related defect in Quality Center, a corresponding 
support message is automatically added in Service Desk. If a new support 
message is created in Service Desk, a corresponding defect is automatically 
added in Quality Center. Any changes you make to a record in one of the 
systems, is automatically updated in the other system.

To work with defect synchronization, you must log in to Quality Center 
with a user that has the appropriate permissions to work with Enterprise 
Integration. For more information on setting Quality Center permissions for 
Enterprise Integration, see “Customizing User Group Permissions for 
Integration with Solution Manager” on page 84.
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Synchronizing Quality Center defects and Service Desk support messages 
includes the following stages:

 1 Create a Solution Manager project and associate it with your Quality Center 
project. You do not need to perform this stage if you have already associated 
your Solution Manager project for requirement and blueprint integration. 
For more information, see “Configuring Solution Manager” on page 53.

 2 Define how fields are mapped between Quality Center defects and Service 
Desk support messages. You must also map specific values of the 
corresponding fields. For more information, see “Creating Field Mappings” 
on page 53.

 3 Create and edit SAP-related defects in Quality Center. For more information, 
see “Managing SAP-Related Defects in Quality Center” on page 59.

 4 At any given time, only one of the systems can be responsible for a defect or 
its corresponding support message. You can transfer responsibility for a 
defect from Quality Center to Service Desk, or request responsibility from 
Service Desk. For more information, see “Exchanging Defect Responsibility” 
on page 61.

 5 Track the progress of synchronization of Quality Center defects with Service 
Desk support messages. You can view defects that are pending 
synchronization, and prompt the synchronization of defects that failed to 
synchronize. For more information, see “Tracking Defect Synchronization in 
Quality Center” on page 62.
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Configuring Solution Manager

You create a project in Solution Manager and associate it with your 
Quality Center project. You can associate each Solution Manager project 
with one Quality Center project only.

To configure Solution Manager:

 1 Create a Solution Manager project in the SOLAR_PROJECT_ADMIN 
transaction. For more information on creating projects in Solution Manager, 
refer to the SAP Application Help.

 2 In the SOLAR_PROJECT_ADMIN transaction, open your Solution Manager 
project and choose Edit > Connection to HP Quality Center.

Enter your Quality Center login details.

Creating Field Mappings

To enable synchronization of Quality Center defects and Service Desk 
support messages, you must map fields in Quality Center defects with their 
corresponding fields in Service Desk support messages.

If the support message fields in your SAP application were changed from the 
default definitions, you must update these definitions in Quality Center.

Mapping fields includes two stages: mapping the field labels and mapping 
the field values. For example, you can map the Quality Center field Severity 
to the Service Desk field Priority. You can then map value 1 of Severity to 
value 5 of Priority.

This section includes the following topics:

➤ Updating Support Message Field Definitions on page 54

➤ Mapping Field Labels on page 55

➤ Mapping Field Values on page 57
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Updating Support Message Field Definitions
If the support message fields in your SAP application were changed from 
their default definitions, you need to update these definitions in 
Quality Center. If the fields in your SAP application were not changed from 
their default definitions, you do not need to take any action.

The support message field definitions are stored on your server machine in 
an xml file. The file contains metadata for the support message fields. For 
example, the following illustration shows the metadata stored for the 
support message Priority field:

The file is divided into two sections: regular fields and fixed fields. Only 
regular fields are displayed in the mapping grids, and you can map them to 
any Quality Center fields. Fixed fields are automatically mapped to 
Quality Center fields, as defined in the MapTo tag.

To update support message field definitions:

 1 On your server machine, open Command Prompt, and navigate to the  
<QC_Installation_Path>\application\30EIServer.war\WEB-INF\lib folder. By 
default, the Quality Center installation path is [drive]:\Program 
Files\Mercury\Quality Center.

 2 Open the EIServer.jar file.

 3 In the list of compressed files, open the SMFieldsMetaData.xml file for 
editing.

 4 Edit the metadata according to the changes in your SAP application.

 5 Save and close the file.

 6 Redeploy the Quality Center archive files. In the Installing Enterprise 
Integration procedure, follow steps 19 to 24.
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Mapping Field Labels
You map fields in Quality Center defects with corresponding fields in 
Service Desk support messages. You must map all required fields. You can 
also map selected non-required fields.

Important: The number of required fields in Quality Center must be 
identical to the number of required fields in SAP. For information on 
defining required fields in Quality Center, refer to the HP Quality Center 
Administrator Guide.

To map a field:

 1 In Quality Center, select Tools > SAP Tools > Field Mapping. The Field 
Mapping dialog box opens.

 2 In the Application box, select the appropriate value.

 3 In the Required Fields section, map a required Quality Center field to a 
required Service Desk field.
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Choose one of the following mapping options:

➤ Select a non-mapped Quality Center field in the left grid that you want 
to map. Potential SAP fields for mapping are displayed in the right grid. 
Select a corresponding field in the right grid, and click the Map Field 
button.

➤ Select an SAP field in the right grid. Potential Quality Center fields for 
mapping are displayed in the left grid. Drag a label from the right grid to 
its corresponding label in the left grid.

Tip: For all the Quality Center fields to reappear, click anywhere outside the 
grids.

The Mapping Status column can contain the following values:

If the mapped Quality Center field requires its values from a list, its 
mapping status changes to Values Mapping not completed. Otherwise, its 
mapping status changes to Valid Mapping.

Repeat this step to map all the required Quality Center fields.

 4 In the Non-Required Fields section, repeat step 3 to map non-required 
Quality Center fields.

Mapping 
Status

Name Description

Not Mapped The Quality Center field is not mapped to a 
Service Desk field.

Value Mapping is 
incomplete

The Quality Center field is mapped to a Service 
Desk field, but the field values mapping is not 
completed.

Valid Mapping Both the Quality Center field and its values are 
mapped respectively to a Service Desk field and 
its values.
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 5 To undo the mapping of a field, drag the SAP Field Label from the left grid to 
the right grid. The Mapping Status changes to Not Mapped. Alternatively, 
select a field in the left grid, and click the Remove Mapping button.

 6 To map the values of the mapped fields, see “Mapping Field Values” on 
page 57.

 7 At the bottom of the dialog box, select Apply "Append Only" mode to 
defects comments. This confirms that, when working with Enterprise 
Integration, you can only add comments to defects, but you cannot edit 
existing comments. If you do not select this option, the synchronization 
will not succeed.

 8 To save the current mappings and continue to work, click Apply.

 9 To reset all field mappings, click the Reset button. After you confirm the 
action, all the mapped SAP fields return to the right grid.

 10 To close the dialog box, click OK. The current mappings are saved and the 
dialog box closes.

Mapping Field Values
For a specific mapped Quality Center field, you map the field values with 
the values of the corresponding Service Desk field.

To map a field value:

 1 In Quality Center, select Tools > SAP Tools > Field Mapping. The Field 
Mapping dialog box opens.

 2 In the Application box, select the appropriate value.

 3 Select a field in the left grid with the Value Mapping is incomplete mapping 
status.
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 4 Click the Value Mapping button. The Value Mapping dialog box opens.

The left grid displays a list of the values for the Quality Center field. The 
right grid displays a list of the values for the SAP field.

 5 Select a value in the left grid and its corresponding value in the right grid, 
and click the Map Value button. Alternatively, drag a value from the right 
grid to its corresponding value in the left grid.

Repeat this step until each QC Value in the left grid is assigned an SAP Value.

Note: 

➤ You can map the same SAP Value to more than one QC Value.

➤ You can map more than one SAP Value to a single QC Value. In that case, 
the QC Value is duplicated in the grid.

 6 To undo the mapping of a QC Value, drag the SAP Value to the right grid. 
Alternatively, select a QC Value and click the Remove Mapping button.
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 7 Click OK. The Value Mapping dialog box closes and the Field Mapping 
dialog box displays. If the value mapping is valid, the Mapping Status of the 
Quality Center field changes to Valid Mapping.

 8 Click OK. The current mappings are saved and the dialog box closes.

Managing SAP-Related Defects in Quality Center

You create SAP-related defects in Quality Center. For each new SAP-related 
defect, a new support message is automatically created in Service Desk. For 
more information, see “Creating SAP-Related Defects in Quality Center” on 
page 60.

If a Quality Center defect has a corresponding Service Desk support message, 
you can edit the defect in Quality Center. Changes you make to the defect 
are automatically updated in the Service Desk support message. For more 
information, see “Editing SAP-Related Defects in Quality Center” on 
page 60.

For information on creating and editing support messages in Service Desk, 
see the SAP Application Help.

The life cycle of defects and support messages is controlled by the Status 
fields in both systems. These are automatically synchronized according to 
specific events:

Event in Application A Synchronization in Application B

New support message created in Service 
Desk.

Quality Center defect status set to 
Open.

Support message confirmed in Service 
Desk.

Quality Center defect status set to 
Closed.

Quality Center defect status set to 
Closed.

Service Desk support message is 
confirmed.

Send Solution to External Service Desk 
selected in Service Desk.

Quality Center defect status set to 
Fixed.

Quality Center defect status set to 
Reopen.

A new support message is created in 
Service Desk, and linked to the defect.
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Creating SAP-Related Defects in Quality Center
You can create SAP-related defects in Quality Center. For each new 
SAP-related defect, a new support message is automatically created in Service 
Desk.

For defects to be synchronized with Service Desk, you must assign them a 
special defect type. In addition, you must complete fields that are required 
in Service Desk.

To create an SAP-related defect:

 1 In the Quality Center Defects module, click the New Defect button.

 2 In the Defect type field, select SAP Related Defect. The SAP Related Defect 
Details tab is added to the New Defect dialog box.

 3 Complete the defect details, including the fields in the SAP Related Defect 
Details tab.

 4 Click Submit. The defect is entered into the Defect Synchronization Pool 
until a corresponding support message is created in Service Desk. To track 
the status of the synchronization, see “Tracking Defect Synchronization in 
Quality Center” on page 62.

While the defect remains in the Defect Synchronization Pool, it is flagged 
with an alert. For more information on viewing alerts, refer to the 
HP Quality Center User Guide.

 5 To transfer responsibility for the defect to Service Desk, see “Exchanging 
Defect Responsibility” on page 61.

Editing SAP-Related Defects in Quality Center
You can edit defects transferred from Service Desk. Changes you make to 
these defects are automatically applied to the corresponding support 
messages in Service Desk.

To be able to make changes to an SAP-related defect in Quality Center, you 
must have responsibility for the defect. For more information, see 
“Exchanging Defect Responsibility” on page 61.
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To edit an SAP-related defect in Quality Center:

 1 In the Defects module, select an SAP Related Defect.

 2 Edit the defect.

Due to SAP limitations, you can add a new comment in the Comments field, 
but you cannot edit existing comments.

 3 If the defect is linked to more than one requirement, in the Transferred 
Requirement field, select the requirement to be transferred to Solution 
Manager.

 4 If the defect is linked to more than one test, in the Transferred Test field, 
select the test to be transferred to Solution Manager.

 5 Click OK to close the defect. The defect is entered into the Defect 
Synchronization Pool until the corresponding support message is updated in 
Service Desk. To track the status of the synchronization, see “Tracking 
Defect Synchronization in Quality Center” on page 62.

While the defect remains in the Defect Synchronization Pool, it is flagged 
with an alert. For more information on viewing alerts, refer to the 
HP Quality Center User Guide.

 6 To transfer responsibility for the defect to Service Desk, see “Exchanging 
Defect Responsibility” on page 61.

Exchanging Defect Responsibility

To make changes to an SAP-related defect in Quality Center, Quality Center 
needs to be responsible for the defect. To allow a Service Desk user to make 
changes to support messages, you must assign him responsibility. 

In Quality Center, you can identify the responsible system, request 
responsibility from Service Desk, and assign responsibility to Service Desk.

➤ To identify the responsible system for the defect, in the Defects module, 
open the defect, select the SAP Related Defect Details tab, and check the 
value in the Responsible System field.

If Quality Center does not have responsibility, you can request the 
responsibility from Service Desk.
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➤ To request responsibility for a defect from Service Desk, navigate to the 
defect in the defects grid, right-click and select Request Responsibility from 
SAP.

After making changes to the defect in Quality Center, you can assign the 
responsibility to Service Desk. You cannot assign responsibility of a defect to 
Service Desk while the defect is in the Synchronization Pool. For more 
information on the Synchronization Pool, see “Tracking Defect 
Synchronization in Quality Center” on page 62

➤ To transfer responsibility for a defect to Service Desk, navigate to the defect 
in the defects grid, right-click and select Assign Responsibility to SAP.

Tracking Defect Synchronization in Quality Center

SAP-related defects that are created or modified in Quality Center are lined 
up for synchronization with Service Desk. Until synchronization is 
completed, the defects are listed in the Defect Synchronization Pool. If a 
defect failed to synchronize, you can prompt its synchronization manually 
from the Defect Synchronization Pool.

To track defect synchronization in Quality Center:

 1 Select Tools > SAP Tools > Manage Defect Synchronization. The Defect 
Synchronization Pool dialog box opens.
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The grid displays all defects in line for synchronization. Each defect is 
assigned one of the following statuses:

 2 If a defect has failed to synchronize, and in the Status Notes field 
Quality Center states that the defect is linked to more than one requirement 
or test, you must select a specific requirement or test:

 a Close the Defect Synchronization Pool and select the relevant defect.

 b Select the SAP Related Defect Details tab.

 c In the Transferred Requirement field or Transferred Test field, select the 
requirement or test to be transferred to Solution Manager.

 3 To prompt the synchronization of a defect in Failed status, select the defect 
and click the Synchronize button.

 4 To prompt the synchronization of all defects currently in Failed status, click 
the Synchronize All button.

 5 To refresh the display, click the Refresh button.

 6 If a defect has failed, or is pending to synchronize, you can remove it from 
the Defect Synchronization Pool. To do so, select the defect and click the 
Delete defects from Synchronization Pool button.

Status Description

Synchronizing The system is currently synchronizing the defect with 
the SAP application.

Pending The defect is lined up to be synchronized.

Failed The system attempted to synchronize the defect, but 
failed. You can prompt another attempt to 
synchronize in the dialog box.

Closing

- Pending to Close

- Failed to Close

The defect in Quality Center is set to Closed and is 
prepared to be confirmed in Service Desk. If failed, you 
can prompt another attempt in the dialog box.

Disconnecting

- Pending to Disconnect

- Failed to Disconnect

The defect is deleted in Quality Center. The system 
attempts to disconnect the corresponding Service Desk 
support message. If failed, you can prompt another 
attempt in the dialog box.



Chapter 3 • Synchronizing Defects and Support Messages

64

64



65

4
Working with the Application Model 
Module

The Application Model module enables you to manage a hierarchical 
representation of the entities in your SAP application. You can import 
entities from your SAP application, and add and modify application entities 
and folders. You can also associate application entities with tests or business 
components. The Application Model module is automatically enabled when 
you enable Enterprise Integration for a Quality Center project.

This chapter includes:

 ➤  About Working with the Application Model Module on page 66

 ➤  Viewing Application Entities on page 67

 ➤  Importing the SAP Application Hierarchy on page 69

 ➤  Adding Folders and Application Entities Manually on page 71

 ➤  Modifying Folders and Application Entities on page 73

 ➤  Associating Application Entities with Tests on page 75

 ➤  Associating Application Entities with Business Components on page 79
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About Working with the Application Model Module

You use the Application Model module to manage a representation of your 
SAP application components and entities. For example, if you link your SAP 
application components and application entities to tests, you can see which 
tests you need to run when changes affecting these components and entities 
are made in your application.

You can import SAP components and application entities from your SAP 
application.When you import directly from your SAP application, the 
hierarchy of the elements in the application and the basic data for each 
business entity are preserved. If you want to extend the scope at any stage, 
you can import the application hierarchy again, without overwriting 
existing entities in the Application Model module.  

You can also manually add and modify application entities in the 
Application Model module. Note that this does not affect corresponding 
application entities in your SAP application.

After you develop your application model tree, you can associate each 
application entity with tests in the Test Plan module. If your Quality Center 
server is licensed for Business Process Testing, you can also associate an 
application entity with a business component. Each business process test 
containing that business component is then associated with all of the 
application entities associated with that component.
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Viewing Application Entities

You import, add, and modify application entities using the Application 
Model module. To open the Application Model module, click the 
Application Model button on the sidebar. 

You can view your application entities in The Application Model Tree or the 
The Application Model Grid.

The Application Model Tree
You can view a hierarchical representation of your application entities in the 
application model tree. To view the application model tree, select View > 
Application Model Tree.

By default, each folder  in the application model tree represents an SAP 
application component in your SAP application. During the Learn Flow 
process, a folder with the name of the flow is created for any flow 
representing a transaction whose application entity is not in the application 
model tree. Each application entity  represents an application entity in 
your SAP application.



Chapter 4 • Working with the Application Model Module

68

68

The Application Model Grid
You can view all the application entities in a Quality Center project from the 
Application Model Grid. Each row displays a separate application entity. 
Each column represents a separate data item. To view the Application Model 
Grid, select View > Application Model Grid. 

The following columns are displayed for each entity:

Column Description

Code The code of the entity in the SAP application.

Description The description of the entity in the SAP application.

Entity ID A unique numerical ID assigned by Quality Center to the 
application entity. This ID cannot be modified.

Entity Name The name of the entity in the SAP application.

Folder The folder in the application model tree in which the 
application entity is located. Each folder represents an 
SAP application element. 

Is Active This column is relevant only for Change Impact Testing 
module for SAP applications. For more information, see 
the HP Change Impact Testing module for SAP applications 
User’s Guide. 
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Importing the SAP Application Hierarchy

You can import the application hierarchy to the Application Model module. 
This maps the entities in your SAP application to application entities in the 
Application Model module, reproducing the same hierarchical structure. 
Each SAP application element is represented as a folder. Each folder contains 
representations of the application entities that are included in the SAP 
application element in your SAP application. 

You can import the application hierarchy more than once. For example, if 
you add new entities to your SAP application, you may want to include 
them in the application hierarchy, or you may decide to include application 
entities that were previously out of scope. When you import application 
entities that are already in the Application Model module, the data that you 
entered for each application entity is preserved. Any associations you 
created with tests and business components are also preserved.

Modified The date and time when the application entity was last 
modified.

Type The type of SAP application entity, for example, SAP 
Transaction. 

Column Description
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To import the application hierarchy:

 1 In the Application Model module, display the application model tree and 
select Application Entities > Import Application Model. The Import 
Application Model Wizard dialog box opens.

 2 Type the login details for your SAP application and click Next. 
Quality Center connects to your SAP application and the Select Application 
Components dialog box opens, displaying the SAP components in your SAP 
application. (You can view the same hierarchy in your SAP application using 
the SE81 transaction.)
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 3 Select the SAP application elements you want to import to the Application 
Model module. When these application components are imported, all child 
application entities are also imported. Click Next.

Note: You can also import user transactions that are not assigned to any 
application component. To import these transactions, select the User 
Transactions (Unassigned) node in the Select Application Components 
dialog box.

 4 Click Import to import the SAP components and application entities to the 
Application Model module. Note that this process may take some time. 
When the import process is finished, a confirmation message displays. Click 
OK.

 5 Click Close to close the Import Application Model Wizard.

The application components you selected are imported to the Application 
Model module. The hierarchical structure of the SAP application 
components is reproduced in the Application Model module, with the 
top-level components located under the SAP folder.

When you import application entities to the Application Model module, a 
default values are assigned to various fields for each imported application 
entity. These default values are based on the properties of the entity in the 
SAP application. 

Adding Folders and Application Entities Manually

You can add folder and application entities manually.

Tip: You can also import folders and application entities using the Import 
Application Model Wizard. For more information, see “Importing the SAP 
Application Hierarchy” on page 69.
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To add a folder:

 1 In the application model tree, select a folder and click the New Folder 
button, or select Application Entities > New Folder. The New Folder dialog 
box opens.

 2 In the Folder Name box, type a name for the folder and click OK. The new 
folder is added to the application model tree under the folder you selected 
in step 1.

 3 You can add a description for the new folder in the Description tab in the 
right pane.

 4 You can add an attachment to the new folder in the Attachments tab. For 
more information on adding attachments, see the HP Quality Center User 
Guide.

To add an application entity:

 1 In the application model tree, select a folder and click the New Entity 
button, or select Application Entities > New Entity. The New Application 
Entity dialog box opens.
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 2 In the Application Entity Name box, type the name of the application entity. 
This is a required field.

 3 In the Application Entity Code box, type the unique code of the application 
entity. This is a required field.

 4 In the Description box, type a description of the application entity.

 5 Click OK. The new application entity is added to the application model tree 
under the folder you selected in step 1.

Modifying Folders and Application Entities

You can rename and delete folders and application entities in the 
Application Model module.

Renaming Folders and Application Entities
You can rename a folder or application entity in the Application Model 
module.

To rename a folder or application entity:

➤ To rename a folder or application entity in the application model tree, select 
a folder or application entity and select Edit > Rename. Alternatively, 
right-click the folder or application entity and select Rename. Edit the name 
and press ENTER.

➤ To rename an application entity in the Application Model Grid, click the 
name of the application entity and type the new name.
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Deleting Folders and Application Entities
You can delete a folder or application entity from the application model 
tree. When you delete a folder, you can choose to delete the folder and its 
subfolders, or you can choose to delete the folder, its subfolders, and 
application entities. 

➤ If you delete a folder with its subfolders, all of the application entities are 
moved to the Unattached folder in the application model tree. 

➤ If you delete a folder with its subfolders and application entities, all 
subfolders and application entities under the selected folder are deleted 
permanently. 

To delete a folder:

 1 Select a folder from the application model tree.

 2 Click the Delete button, or select Edit > Delete. Alternatively, right-click the 
folder and select Delete. The Confirm Delete Folder dialog box opens.

 3 Select Delete folders only or Delete folders and application entities.

 4 Click Yes.

To delete an application entity:

 1 Select an application entity from the application model tree or Application 
Model Grid.

 2 Click the Delete button, or select Edit > Delete. Alternatively, right-click the 
application entity and select Delete.

 3 Click Yes to confirm.
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Associating Application Entities with Tests 

You can associate the application entities you created in the Application 
Model module with tests from the Test Plan module. You can perform this 
task from the Application Model module or from the Test Plan module.

Associating Application Entities Using the Application 
Model Module
You can associate application entities with tests using the Application Model 
module.

To associate application entities with tests using the Application Model 
module:

 1 In the application model tree, select an application entity and click the 
Linked Tests tab. The Linked Tests tab displays the coverage grid for the 
selected application entity.

For information on the columns in the Linked Tests tab, see the HP Quality 
Center User Guide.
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 2 In the Linked Tests tab, click the Select Tests button to show the test plan 
tree on the right.

 3 To search for a specific test in the tree, type the name (or part of the name) 
of the test in the Find box and click the Find button. If the search is 
successful, the test is highlighted in the tree.

 4 To refresh all of the tests in the test plan tree, click the Refresh All button.

 5 Select a test or test folder to add to the application entity’s test coverage. 
Click the Link Tests To Application Entity button. The test is added to the 
coverage grid.

 6 To refresh the application entities in the coverage grid, click the Refresh All 
button above the grid. 

 7 To filter the application entities displayed in the coverage grid, choose one 
of the following options from the Show Entities box:

➤ Linked Directly. Displays those tests that are associated directly with the 
application entity.

➤ Linked Through Other Assets. Displays those tests that are associated 
with the application entity via business components.

➤ All. Displays all of the application entities that are associated with the 
test. 
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 8 Click the Close button to hide the test plan tree.

Notes: 

➤ To modify the data in the coverage grid columns or to remove tests from 
the coverage grid, you must first select Linked Directly in the Show 
Entities box.

➤ To remove test coverage from the Application Model module, verify that 
Linked Directly is displayed in the Show Entities box. Then select the test 
you want to remove from coverage and click the Remove Link button. 
Click Yes to confirm.

Associating Application Entities Using the Test Plan 
Module
You can associate application entities with tests using the Test Plan module.

To associate application entities with tests using the Test Plan module:

 1 In the test plan tree, select the test you want to associate with one or more 
entities, and click the Application Entities tab. The application entities 
associated with the selected test are displayed.
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 2 In the Application Entities tab, click the Select Application Entities button 
to show the application model tree on the right.

 3 To search for a specific application entity in the tree, type the name (or part 
of the name) of the application entity in the Find box and click the Find 
button. If the search is successful, the application entity is highlighted in 
the tree.

 4 To refresh all of the application entities in the application model tree, click 
the Refresh All button.

 5 Select an application entity or application folder to add to the test’s 
application entity coverage. Click the Add Entity to Linkage button. The 
application entity is added to the coverage grid.

 6 To refresh the application entities in the coverage grid, click the Refresh All 
button above the grid.

 7 To filter the application entities displayed in the coverage grid, choose one 
of the following options from the Show Entities box:

➤ Linked Directly. Displays those application entities that are associated 
directly with the test.

➤ Linked Through Other Assets. Displays those application entities that 
are associated with business components via business process tests.

➤ All. Displays all of the application entities that are associated with the 
test. 
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 8 Click the Close button to hide the application model tree.

Notes: 

➤ To modify the data in the coverage grid columns or to remove 
application entities from the coverage grid, you must first select Linked 
Directly in the Show Entities box.

➤ To remove application entity coverage from the Test Plan module, verify 
that Linked Directly is displayed in the Show Entities box. Then select the 
application entity you want to remove from coverage and click the 
Remove Link button. Click Yes to confirm.

Associating Application Entities with Business Components

You can associate an SAP entity with any type of test, including a business 
process test. To associate an entity with a business process test, you first 
associate the entity with one or more business components. Then, when 
you include these business components in a business process test, the test is 
automatically associated with the entities that are a part of the business 
process test’s business components. For details on adding business 
components to a business process test, see the HP Business Process Testing 
User Guide.

You associate application entities with business components using the 
Business Components module. After they are associated, you can manage 
your associated application entities either from the Application Model 
module or from the Business Components module.

To manually associate application entities with business components:

 1 In the component tree, select the component you want to associate with 
one or more application entities, and click the Application Entities tab. The 
application entities associated with the selected business component are 
displayed. For a description of each column displayed, see “The Application 
Model Grid” on page 68.
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 2 In the Application Entities tab, click the Select Application Entities button 
to show the application model tree on the right.

 3 To search for a specific application entity in the tree, type the name (or part 
of the name) of the application entity in the Find box and click the Find 
button. If the search is successful, the application entity is highlighted in 
the tree.

 4 To refresh all of the application entities in the application model tree, click 
the Refresh All button.

 5 Select an application entity or application folder to add to the business 
component’s application entity coverage. Click the Add Entity to Linkage 
button. The test is added to the coverage grid.

 6 Click the Close button to hide the application model tree.

Note: To remove application entity associations from the Business 
Components module, select the application entity for which you want to 
remove an association, click the Remove Link button, and click Yes to 
confirm.
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Customizing Enterprise Integration

You can customize user group permissions, hide data for a user group and 
customize project entities for Enterprise Integration.

This chapter includes:

 ➤  About Customizing Enterprise Integration on page 81

 ➤  Customizing User Group Permissions on page 82

 ➤  Hiding Data for a User Group on page 85

 ➤  Customizing Project Entities on page 86

About Customizing Enterprise Integration

You can customize entities in the Application Model module, which is 
enabled automatically when you enable Enterprise Integration. You 
customize these entities in the same way as you customize other entities in 
your Quality Center projects. You can restrict which user groups can add, 
delete and modify folders and application entities. You can also determine 
which application entities and application entity fields each user group can 
view. In addition, you can add and customize Application Model fields.

You can also customize which Quality Center user groups can export 
business blueprints from Solution manager, and which user groups can 
update business blueprints.

This chapter describes the additional customization options available with 
Enterprise Integration. For more information on project customization, refer 
to the HP Quality Center Administrator Guide.
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Customizing User Group Permissions

You can customize the permission settings for the Application Model 
module and for the integration with Solution Manager in the Permission 
Settings dialog box in Project Customization. For more information on user 
group permissions, refer to the HP Quality Center Administrator Guide.

Customizing User Group Permissions for the Application 
Model Module
The Application Model tab displays the tasks available in the Application 
Model module. 
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The Application Model tab includes the following tasks:

Task Description

Add Application Entity User group can add application entities to the 
Application Model module. A user group must have 
permissions for this task and for the Modify 
Application Entity task to import SAP application 
entities.

Modify Application Entity User group can modify application entities in the 
Application Model module. Note that this task 
enables you to specify the fields that the selected 
user group can modify. A user group must have 
permissions for this task and for the Add 
Application Entity task to import SAP application 
entities.

Delete Application Entity User group can delete application entities from the 
Application Model module.

Move Application Entity User group can move application entities in the 
Application Model module.

Add Folder User group can add folders to the Application Model 
Tree.

Modify Folder User group can modify folders in the Application 
Model Tree. Note that this task enables you to 
specify the fields that the selected user group can 
modify.

Delete Folder User group can delete folders from the Application 
Model Tree.

Move Folder User group can move folders in the Application 
Model Tree.

Add Link to Asset User group can associate application entities with 
tests and business components.

Delete Link from Asset User group can remove association of application 
entities with tests and business components.
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Customizing User Group Permissions for Integration with 
Solution Manager
The Blueprint tab displays the tasks available for integration with Solution 
Manager. 

The Blueprint tab includes the following tasks:

Task Description

Retrieve Data from Solution 
Manager

User group can import business blueprints, and 
connect to Quality Center from Solution Manager 
and export business blueprints. 

Send Data to Solution 
Manager

User group can update Solution Manager with 
Quality Center test results.

Map Defect Fields User group can create field mappings for 
Quality Center defects and Service Desk support 
messages.

Manage Defect 
Synchronization

User group can access the defect pool to manage the 
synchronization of Quality Center defects and 
Service Desk support messages.
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Hiding Data for a User Group

You can instruct Quality Center to hide specific application entities and 
application entity fields that a user group can view in the Application Model 
module.

You can set filters for specific fields, limiting the application entities that the 
user group can view. For example, you can set the filter for the field Type to 
SAP Batch Job. This instructs Quality Center to allow users belonging to the 
user group to view only application entities that are SAP batch jobs. You set 
filters in the Filter Condition tab in the Application Model Data-Hiding 
Filter dialog box. For more information on hiding data for a user group, refer 
to the HP Quality Center Administrator Guide.

You can filter by the following fields: Application, Code, Entity ID, Entity 
Name, Folder, Is Active, Modified, and Type. For more details on these fields, 
see “The Application Model Grid” on page 68.
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You can also select which fields in the Application Model module the user 
group can see and which should be hidden. You select these fields in the 
Visible Fields tab in the Application Model Data-Hiding Filter dialog box.

You can choose to hide the following fields: Application, Description, 
Folder, Is Active, Modified, and Type. For more details on these fields, see 
“The Application Model Grid” on page 68.

Customizing Project Entities

You can customize the system fields and add new user-defined fields for the 
Application Model module from the Customize Project Entities dialog box. 
You customize these fields under the Application Entity entity. For more 
information on customizing project entities, refer to the HP Quality Center 
Administrator Guide.
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