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Welcome

Welcome to the TestDirector Microsoft Excel Add-in, which enables you to 
export requirements, tests, and defects from Microsoft Excel directly to 
TestDirector.

This add-in supports Microsoft Excel 97, 2000, 2003, and XP with 
TestDirector 8.0 Standard and Enterprise editions. 

Note: This guide explains how to use Microsoft Excel with TestDirector. For 
additional information on using TestDirector, refer to the TestDirector User’s 
Guide.

Using This Guide

This guide contains two chapters:

 Chapter 1 Installing and Configuring the Microsoft Excel Add-in

Describes how to install the Microsoft Excel Add-in and how to configure 
your Microsoft Excel security settings so that you can work with this add-in.

 Chapter 2 Exporting Data to TestDirector

Describes how to export the Microsoft Excel worksheet to TestDirector.
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Documentation Updates

Mercury Interactive is continuously updating its product documentation 
with new information. You can download the latest version of this 
document from the Customer Support Web site 
(http://support.mercuryinteractive.com).

To download updated documentation:

 1 In the Customer Support Web site, click the Documentation link.

 2 Under Select Product Name, select TestDirector.

Note that if TestDirector does not appear in the list, you must add it to your 
customer profile. Click My Account to update your profile.

 3 Click Retrieve. The Documentation page opens and lists the documentation 
available for the current release and for previous releases. If a document was 
recently updated, Updated appears next to the document name.

 4 Click a document link to download the documentation.

Typographical Conventions

This book uses the following typographical conventions:

1, 2, 3 Bold numbers indicate steps in a procedure.

➤ Bullets indicate options and features.

> The greater than sign separates menu levels (for 
example, File > Open).

Stone Sans The Stone Sans font indicates names of interface 
elements in a procedure that you perform actions 
upon (for example, “Click the Run button.”).

Bold Bold text indicates function names.

Italics Italic text indicates variable names, or introduces a 
new term.

Arial The Arial font is used for examples and statements that 
are to be typed in literally.
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1
Installing and Configuring the Microsoft 
Excel Add-in

To export requirements, test plans, or defects from Microsoft Excel to 
TestDirector, you must install the Microsoft Excel Add-in on your client 
machine.

This chapter describes:

➤ Installing the Microsoft Excel Add-in

➤ Configuring the Microsoft Excel Security Settings

➤ Upgrading Microsoft Excel

Installing the Microsoft Excel Add-in

This section describes how to install the Microsoft Excel Add-in. Note that 
you must install Microsoft Excel on your client machine before you install 
the add-in.

Note: To install this add-in, you must log in with administrator privileges.

To install the Microsoft Excel Add-in:

 1 Close Microsoft Excel.

 2 Uninstall any previous versions of the Microsoft Excel Add-in. To uninstall, 
choose Start > Settings > Control Panel > Add/Remove Programs and follow 
the instructions on your screen.
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 3 Open your Web browser and type your TestDirector URL: 
http://[TestDirector server name]/[virtual directory name]/default.htm.
The TestDirector Options window opens.

 4 Click the Add-ins Page link. The TestDirector Add-ins page opens.
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 5 Click the More TestDirector Add-ins link. The More TestDirector Add-ins 
page opens.

 6 Click the Microsoft Excel link. The Microsoft Excel Add-in page opens.

 7 Click the Download Add-in link. Follow the on-screen installation 
instructions.

 8 Navigate back to the TestDirector Add-ins page and click the TestDirector 
Connectivity Add-in link. The TestDirector Connectivity Add-in opens.

 9 Click Download Add-in and install the Connectivity Add-in on your 
TestDirector client machine.

 10 If you are using Office 97, you must open the TDExcelAddin.xla file in the 
Microsoft Office XLStart folder.

 11 If you are using Microsoft Excel 2000, 2003, or XP, you must set your 
Microsoft Excel security settings after you install the Excel Add-in. For more 
information, see “Configuring the Microsoft Excel Security Settings”.

Configuring the Microsoft Excel Security Settings

If you are working with Microsoft Excel 2000, 2003, or XP, after you install 
the Microsoft Excel Add-in, you must also configure your Microsoft Excel 
security settings.
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To configure the Microsoft Excel security settings:

 1 In Microsoft Excel, choose Tools > Macro > Security. The Security dialog box 
opens.

 2 In Microsoft Excel 2000, select one of the following options:

➤ Select Medium. In the Trusted Sources tab, select Trust all installed add-
ins and templates. Click OK to close the Security dialog box. 

➤ Select Low. In the Trusted Sources tab, clear Trust all installed add-ins 
and templates. Click OK to close the Security dialog box. Close and 
reopen Microsoft Excel. The macros dialog box opens. Click Enable 
Macros to enable the Microsoft Excel Add-in.

 3 In Microsoft Excel 2003 or Microsoft Excel XP, to set the security settings:

Select Medium. In the Trusted Sources tab, clear Trust all installed add-ins 
and templates. Click OK to close the Security dialog box. Close and reopen 
Microsoft Excel. The macros dialog box opens. Click Enable Macros to 
enable the Microsoft Excel Add-in.
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Upgrading Microsoft Excel

If you upgrade Microsoft Excel after working with this add-in, you must 
make the Microsoft Excel Add-in accessible to the new version of Microsoft 
Excel. 

To use this add-in after upgrading Microsoft Excel:

 1 In your file management application, navigate to: 
<drive>:\Program Files\Microsoft Office\Office<old version>\XLStart\TDAddin

 2 Copy the TDAddin folder to: 
<drive>:\Program Files\Microsoft Office\Office<new version>\XLStart

You can now use the Microsoft Excel Add-in.



TestDirector Microsoft Excel Add-in Guide

6



7
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Exporting Data to TestDirector

After you install the Microsoft Excel Add-in, you can define requirements, 
tests, or defects in Microsoft Excel and export them to TestDirector.

This chapter describes:

➤ Defining Requirements

➤ Defining Tests

➤ Defining Defects

➤ Exporting to TestDirector

Defining Requirements

Before you export your requirements to TestDirector’s Requirements 
module, you define the requirements in your worksheet. You can define the 
requirements to be displayed on the same hierarchical level, or different 
hierarchical levels in your requirements tree.

For example, the following requirements are defined on the same 
hierarchical level:
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After you export the requirements to TestDirector, the requirements are 
displayed on the same hierarchical level.

You can also define requirements on different hierarchical levels in the 
requirements tree. For example, suppose you want to define Child_1 and 
Child_2 as children of Requirement_4, and Child_3 as a child of Child_2. To 
define requirements as children, you must define a path for each child as 
defined in the following example: 
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After you export the requirements to TestDirector, the requirements are 
displayed on different hierarchical levels in the requirements tree.

To define a requirement:

 1 Open Microsoft Excel and open your worksheet. 

 2 Define each requirement on a separate row. For each requirement, you must 
define all required fields as indicated in your TestDirector project. If you are 
defining requirements on different hierarchical levels, you must also specify 
the path. 

 3 Export the requirements to TestDirector. For more information, see 
“Exporting to TestDirector,” on page 13.
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Defining Tests

Before you export your tests to TestDirector’s Test Plan module, you define 
the tests in your worksheet. You can define the tests to be displayed on the 
same hierarchical level, or different hierarchical levels in your test plan tree.

For example, suppose you want to define Test 1 and Test 2 on the same 
hierarchical level in the Subject 1 folder:

After you export the tests to TestDirector, the tests are displayed on the same 
hierarchical level in the test plan tree. 

You can also define tests on different hierarchical levels in the test plan tree. 
For example, suppose you want to define Test 3 under Subject 2,which is a 
subfolder under Subject 1. 

After you export the tests to TestDirector, Test 3 is displayed on a different 
hierarchical level in the test plan tree. 
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To define a test:

 1 Open Microsoft Excel and open your worksheet. 

 2 Define each test on a separate row. For each test, you must define all 
required fields as indicated in your TestDirector project. You must also 
specify the Subject folder in the test plan tree in which the test resides.

 3 Export the tests to TestDirector. For more information, see “Exporting to 
TestDirector,” on page 13.

Defining Defects

Before you export your defects to TestDirector’s Defects module, you define 
the defects in your worksheet. For example, suppose you want to export the 
following information:
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After you export the defects to TestDirector, the defects are displayed in the 
Defects module.

To define a defect:

 1 Open Microsoft Excel and open your worksheet. 

 2 Define each defect on a separate row. For each defect, you must define all 
required fields as indicated in your TestDirector project.

 3 Export the defects to TestDirector. For more information, see “Exporting to 
TestDirector,” on page 13.
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Exporting to TestDirector

After you define requirements, tests, or defects in your worksheets, you can 
export them to TestDirector.

Notes: 

➤ Before you export requirements and tests to TestDirector, make sure that 
they have unique names. If a name is not unique, it will be overwritten. For 
example, suppose your worksheet contains two requirements in a particular 
hierarchy with the same name, only one will be created. Its value will be 
that of the second requirement. The same applies to the design steps of a 
test. If there are design steps without a name, or if more than one design 
step with the same name exists, then only a single design step will be 
created. 

➤ When you export a new or existing requirement, test, or defect to 
TestDirector, it is created with the user name that you use to export it. For 
example, if you export a defect to TestDirector with 'steve' as the user name, 
the defect’s history shows 'steve' as the person that changed the defect.

➤ You must have full create and modify permissions in TestDirector for the 
type of record that you are exporting. For example, if you are exporting 
tests, you must have permissions for adding and modifying the test plan 
tree, design steps, and folders. 

To export to TestDirector:

 1 Define the requirements in your worksheet. For more information, see 
“Defining Requirements,” on page 7.

Define the tests in your worksheet. For more information, see “Defining 
Tests,” on page 10.

Define the defects in your worksheet. For more information, see “Defining 
Defects,” on page 11.

 2 Highlight the columns without the column headings. 
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 3 Choose Tools > Export to TestDirector. The TestDirector Export Wizard - Step 
1 of 8 dialog box opens.

Type your TestDirector server and the virtual directory name 
(http://<TestDirector server name>/<virtual directory name>). For example, 
http://myserver/tdbin.

 4 Click Next. The TestDirector Export Wizard - Step 2 of 8 dialog box opens. 

Select a domain and project name. 
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 5 Click Next. The TestDirector Export Wizard - Step 3 of 8 dialog box opens.

Type your user name and password. 

 6 Click Next. The TestDirector Export Wizard - Step 4 of 8 dialog box opens.

Select a data type.
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 7 Click Next. The TestDirector Export Wizard - Step 5 of 8 dialog box opens.

To create a map for mapping TestDirector fields to Microsoft Excel columns, 
you can:

➤ Select an existing map.

➤ Create a new map.

➤ Create a temporary map that will not be saved.

Note: If you upgraded to a newer version of Microsoft Excel and your 
existing maps are unavailable, you can make them accessible again. 
For more information, see “Upgrading Microsoft Excel,” on page 5.
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 8 Click Next. The TestDirector Export Wizard - Step 6 of 8 dialog box opens.

To map a TestDirector field to a corresponding Microsoft Excel column, 
choose a field name from the list on the left, and click the arrow button (>). 
The Map Field with Column dialog box opens. Type a corresponding 
column letter and click OK.

To remove a field mapping, choose a field name from the list on the right, 
and click the arrow button (<). Click the double arrow button (<<) to 
remove all fields.

Note: You must map fields that are marked in red.
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 9 Click Next. The TestDirector Export Wizard - Step 7 of 8 dialog box opens. 

 10 If an error occurs while exporting the worksheet, the TestDirector Export 
Wizard - Scan Error Report dialog box opens. 

Review the errors. To save the errors as a text file, click the Launch Notepad 
button. 

To exit the wizard, click Cancel. Correct the errors and start again at step 1 
on page 13.
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 11 If you have successfully exported your worksheet to TestDirector, the 
TestDirector Export Wizard - Step 8 of 8 dialog box opens.

Click Finish.
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