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Welcome to the TestDirector Microsoft 
Word Add-in

Welcome to the TestDirector Microsoft Word Add-in, which enables you to 
export your defined requirements or test plan from Microsoft Word directly 
to TestDirector’s requirements tree or test plan tree. 

This add-in supports Microsoft Word 97, 2000, 2003, and XP with 
TestDirector 8.0 Standard and Enterprise Editions.

Note: This guide explains how to use Microsoft Word with TestDirector. For 
additional information on using TestDirector, refer to the TestDirector User’s 
Guide.

Using This Guide

This guide contains two chapters:

 Chapter 1 Installing and Configuring the Microsoft Word Add-in

Describes how to install the Microsoft Word Add-in, and how to configure 
the Microsoft Word security settings.

 Chapter 2 Exporting Data to TestDirector

Describes how to define requirements and test plans, and how to export 
them to TestDirector.
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Documentation Updates

Mercury Interactive is continuously updating its product documentation 
with new information. You can download the latest version of this 
document from the Customer Support Web site 
(http://support.mercuryinteractive.com).

To download updated documentation:

 1 In the Customer Support Web site, click the Documentation link.

 2 Under Select Product Name, select TestDirector.

Note that if TestDirector does not appear in the list, you must add it to your 
customer profile. Click My Account to update your profile.

 3 Click Retrieve. The Documentation page opens and lists the documentation 
available for the current release and for previous releases. If a document was 
recently updated, Updated appears next to the document name.

 4 Click a document link to download the documentation.

Typographical Conventions

This book uses the following typographical conventions:

1, 2, 3 Bold numbers indicate steps in a procedure.

➤ Bullets indicate options and features.

> The greater than sign separates menu levels (for 
example, File > Open).

Stone Sans The Stone Sans font indicates names of interface 
elements in a procedure that you perform actions 
upon (for example, “Click the Run button.”).

Bold Bold text indicates function names.

Italics Italic text indicates variable names, or introduces a 
new term.

Arial The Arial font is used for examples and statements that 
are to be typed in literally.
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1
Installing and Configuring the Microsoft 
Word Add-in

This chapter describes how to install and configure the Microsoft Word
Add-in on your client machine. This add-in enables you to export 
requirements or test plans from Microsoft Word to TestDirector. 

This chapter describes:

➤ Installing the Microsoft Word Add-in

➤ Configuring the Microsoft Word Security Settings

Installing the Microsoft Word Add-in

Before you install the Microsoft Word Add-in, make sure that Microsoft 
Word is installed on your client machine.

Note: To install this add-in, you must log in with administrator privileges.

To install the Microsoft Word Add-in:

 1 Close Microsoft Word.

 2 Uninstall any previous versions of the Microsoft Word Add-in. To uninstall, 
choose Start > Settings > Control Panel > Add/Remove Programs. Select 
TestDirector Microsoft Word Add-In and follow the instructions on your 
screen.
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 3 Open your Web browser and type your TestDirector URL: 
http://[TestDirector server name]/[virtual directory name]/default.htm.
The TestDirector Options window opens.

 4 Click the Add-ins Page link. The TestDirector Add-ins page opens.
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 5 Click the More TestDirector Add-ins link. The More TestDirector Add-ins 
page opens.

 6 Under Microsoft Add-ins, click the Microsoft Word link. The Microsoft 
Word Add-in page opens.

 7 Click the Download Add-in link. Follow the on-screen installation 
instructions.

 8 Navigate back to the TestDirector Add-ins page and click the TestDirector 
Connectivity Add-in link. The TestDirector Connectivity Add-in opens.

 9 Click Download Add-in and install the Connectivity Add-in on your 
TestDirector client machine.

 10 If you are using Microsoft Word 2000, 2003, or XP, you must also set your 
Microsoft Word security settings after you install the Microsoft Word Add-
in. For more information, see “Configuring the Microsoft Word Security 
Settings”.

Configuring the Microsoft Word Security Settings

If you are working with Microsoft Word 2000, 2003, or XP, after you install 
the Microsoft Word Add-in, you must also configure your Microsoft Word 
security settings.
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To configure the Microsoft Word security settings:

 1 In Microsoft Word, choose Tools > Macro > Security. The Security dialog box 
opens.

 2 In Microsoft Word 2000, select one of the following options:

➤ Select Medium. In the Trusted Sources tab, select Trust all installed add-
ins and templates. Click OK to close the Security dialog box. 

➤ Select Low. In the Trusted Sources tab, clear Trust all installed add-ins 
and templates. Click OK to close the Security dialog box. Close and 
reopen Microsoft Word. The macros dialog box opens. Click Enable 
Macros to enable the Microsoft Word Add-in.

 3 In Microsoft Word 2003 or Microsoft Word XP, to set the security settings:

Select Medium. In the Trusted Sources tab, clear Trust all installed add-ins 
and templates. Click OK to close the Security dialog box. Close and reopen 
Microsoft Word. The macros dialog box opens. Click Enable Macros to 
enable the Microsoft Word Add-in.
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Exporting Data to TestDirector

After installing the Microsoft Word Add-in, you can define requirements or 
test plans in a Microsoft Word document, and export them to TestDirector.

This chapter describes:

➤ The Microsoft Word Window

➤ Defining Requirements

➤ Defining Test Plans

➤ Exporting to TestDirector



TestDirector Microsoft Word Add-in Guide

6

The Microsoft Word Window

After you install the Microsoft Word Add-in, open Microsoft Word. 

The Microsoft Word Add-in adds the following toolbars:

➤ TestDirector Common toolbar, containing buttons commonly used when 
exporting requirements and test plans. To display or hide the toolbar, 
choose View > Toolbars > TestDirector Common. 

➤ TestDirector Test Plan toolbar, containing buttons used when defining test 
plans. To display or hide the toolbar, choose View > Toolbars > TestDirector 
Test Plan.

➤ TestDirector Requirements toolbar, containing buttons used when defining 
requirements. To display or hide the toolbar, choose View > Toolbars > 
TestDirector Requirements.

TestDirector 
Common 
toolbar

TestDirector 
Test Plan 
toolbar

TestDirector 
Requirements 
toolbar
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Defining Requirements

Before you can export your requirements to TestDirector, you define the 
requirements in your document. To define a requirement, highlight a 
requirement text line and click a button on the TestDirector Requirements 
toolbar. An icon is added next to the text line. You can define the following 
details for each requirement:

You can define the requirements so that when you export them to 
TestDirector, the requirements are displayed on the same hierarchical level, 
or different hierarchical levels in your requirements tree.

To define Click 
Icon 
created

a requirement

the review status of a requirement

the author of a requirement

the priority of a requirement

the description of a requirement

the hierarchical level of a requirement 
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For example, suppose that in your document you defined two requirements: 
Requirement_1 and Requirement_2.
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To define the requirements on the same hierarchical level in the 
requirements tree, you must close each requirement as defined in the 
following example: 

After you export the requirements to TestDirector, the requirements are 
displayed on the same hierarchical level. 



TestDirector Microsoft Word Add-in Guide

10

You can also define requirements on different hierarchical levels in the 
requirements tree. For example, suppose you want to define Requirement_2 
as a child of Requirement_1, and Requirement_3 and Requirement_4 as children 
of Requirement_2. You must close each requirement as defined in the 
following example: 
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After you export the requirements to TestDirector, Requirement_2 is displayed 
as a child of Requirement_1, and Requirement_3 and Requirement_4 are 
displayed as children of Requirement_2. 

To define a requirement:

 1 Start Microsoft Word, and open your requirements document.

 2 Highlight a text line in your document, and click a button on the 
TestDirector Requirements toolbar. Repeat for each text line. 

 3 To define requirements on the same hierarchical level, insert a line at the 
end of each requirement, and click the Close Requirement button.

To define requirements on different hierarchical levels, insert a line at the 
end of the last requirement, and click the Close Requirement button. Repeat 
for each requirement.

 4 To delete a defined object, you can: 

➤ Click the Undo Last button on the TestDirector Common toolbar to 
delete the last entry. A message box opens. Click Yes to delete the object.

➤ Click the Undo All button on the TestDirector Common toolbar to delete 
all objects in the document. Click Yes to delete all objects.

Note: If you delete a defined object manually, you must also delete its 
associated bookmark. If you do not delete the bookmark, an error occurs 
when you attempt to export the object, because it is referring to an existing 
bookmark. To manually delete the associated bookmark, choose Insert > 
Bookmark. The Bookmark dialog box opens. Delete the associated 
bookmark.

 5 Export the requirements to TestDirector. For more information, see 
“Exporting to TestDirector” on page 17.
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Defining Test Plans

Before you can export your test plan to TestDirector, you define the test plan 
in your document. To define a test plan, highlight a text line and click a 
button on the TestDirector Test Plan toolbar. An icon is added next to the 
text line. You can define the following details in your test plan:

You can define the test plan so that when you export it to TestDirector, the 
test subjects are displayed on the same hierarchical level, or different 
hierarchical levels in your test plan tree.

To define Click 
Icon 
created

a subject folder

a test

the current status of a test

the designer of a test

the description of a test

a test step

the description of a step

the expected results of a step 

the hierarchical level of a subject folder
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For example, suppose that in your document you defined two subject 
folders: Subject_1 and Subject_2.
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To define the subject folders on the same hierarchical level in your test plan 
tree, you must close each subject folder as defined in the following example: 

After you export the test plan to TestDirector, the subject folders in the test 
plan tree are displayed on the same hierarchical level.

You can also define subject folders on different hierarchical levels in the test 
plan tree. For example, suppose you want to define Subject_2 as a subfolder 
of Subject_1, and Subject_3 and Subject_4 as subfolders of Subject_2. 
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You must close each subject folder as defined in the following example: 

After you export the test plan to TestDirector, Subject_2 is displayed as a 
subfolder of Subject_1, and Subject_3 and Subject_4 are displayed as 
subfolders of Subject_2.
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To define a test plan:

 1 Start Microsoft Word, and open your test plan document.

 2 Highlight a text line in your document, and click a button on the 
TestDirector Test Plan toolbar. Repeat for each text line. 

 3 To define subject folders on the same hierarchical level, insert a line at the 
end of each subject folder, and click the Close Folder button.

To define subject folders on different hierarchical levels, insert a line at the 
end of the last subject folder, and click the Close Folder button. Repeat for 
each subject folder.

 4 To delete a defined object, you can: 

➤ Click the Undo Last button on the TestDirector Common toolbar to 
delete the last entry. A message box opens. Click Yes to delete the object.

➤ Click the Undo All button on the TestDirector Common toolbar to delete 
all objects in the document. Click Yes to delete all objects.

Note: If you delete a defined object manually, you must also delete its 
associated bookmark. If you do not delete the bookmark, an error occurs 
when you attempt to export the object, because it is referring to an existing 
bookmark. To manually delete the associated bookmark, choose Insert > 
Bookmark. The Bookmark dialog box opens. Delete the associated 
bookmark.

 5 Export the test plan to TestDirector. For more information, see “Exporting to 
TestDirector”.
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Exporting to TestDirector

After you define requirements or test plans in your Microsoft Word 
document, you can export them to TestDirector.

Notes: 

➤ Before you export requirements and tests to TestDirector, make sure that 
they have unique names. If a name is not unique, it will be overwritten. For 
example, suppose your document contains two requirements in a particular 
hierarchy with the same name, only one will be created. Its value will be 
that of the second requirement. The same applies to the design steps of a 
test. If there are design steps without a name, or if more than one design 
step with the same name exists, then only a single design step will be 
created. 

➤ When you export a new or existing requirement or test to TestDirector, it is 
created with the user name that you use to export it. For example, if you 
export a requirement to TestDirector with 'steve' as the user name, the 
requirement’s history shows 'steve' as the person that changed the 
requirement.

➤ You must have full create and modify permissions in TestDirector for the 
type of record that you are exporting. For example, if you are exporting a 
test, you must have permissions for adding and modifying the test plan tree, 
design steps, and folders. 

To export to TestDirector:

 1 Define the requirements in your document. For more information, see 
“Defining Requirements” on page 7. 

 2 Define the test plans in your document. For more information, see 
“Defining Test Plans” on page 12.

 3 To exclude a text area in your document from being exported, highlight the 
text area and click the Exclude Region button. A line is drawn through the 
selected text.
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 4 Click the Export to TestDirector button. The TestDirector Export 
Wizard - Step 1 of 5 dialog box opens.

Type your TestDirector server and virtual directory name: 
http://[TestDirector server name]/[virtual directory name]. 

 5 Click Next. The TestDirector Export Wizard - Step 2 of 5 dialog box opens.

Select a domain and project name. 
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 6 Click Next. The TestDirector Export Wizard - Step 3 of 5 dialog box opens.

Enter your user name and password. 

 7 Click Next. The TestDirector Export Wizard - Step 4 of 5 dialog box opens.
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 8 If an error occurs while exporting the document, the TestDirector Export 
Wizard - Scan Error Report dialog box opens. 

Review the errors. To save the errors as a text file, click the Launch Notepad 
button. 

Click Cancel to exit the wizard. Correct the errors and start again at step 1 
on page 17.
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 9 If you have successfully exported your document to TestDirector, the 
TestDirector Export Wizard - Step 5 of 5 dialog box opens.

Click Finish.
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